php7.0.11升级到php7.3.11安装swoole 过程中出现的问题

最近在公司的开发服务器上平滑升级php7.0.3到php7.3.11的时候,出现了一些错误,下面描述的这两种错误都是同一个原因导致的: ######平台信息: ````bash ubuntu版本 :Ubuntu 16.04.6 LTS \n \l 原php版本:php7.0.11 ```` 升级参考的博客链接,是我很早以前写的,详细链接可以参考: ```bash https:/

- 阅读全文 -

睡觉?

孩子睡觉总踢被子,怕他感冒,把他的腿打断吧,这种问题,你会怎么思考?

- 阅读全文 -

那个人的样子好怪,看着好像一条狗

#### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 #### 那个人样子好怪,他好像一条狗。 ##

- 阅读全文 -

Composer 相关命令的解释

composer 的类似ubuntu ,centos的apt源,yum源,客户端只需要相关的命令就可以实现线上代码的download和install ### composer 的安装 这里不做过多的讲解,原理就是将composer.phar 可执行文件放到linux 全局命令文件中,也就是```sudo mv composer.phar /usr/loca/sbin/composer

- 阅读全文 -

错误提示:apt-get install software-properties-common,sudo: add-apt-repository: command not found

在安装```dnscrypt-proxy``` 的时候,在安装第三方库的时候,也就是```sudo add-apt-repository ppa:shevchuk/dnscrypt-proxy``` ,Launchpad PPA Repositories是很有用的非ubuntu官方的第三方个人资源库,可以很方便地安装第三方软件。 安装的时候会需要额外的软件,直接 执行上述命令的时候会出现: ``

- 阅读全文 -

DnsCrypt 解决dns污染的问题

首先我们查看一下dns劫持和dns污染的定义 ####什么是DNS劫持 DNS劫持一般发生在某些网络运营商身上,DNS劫持就是劫持了DNS服务器,获取DNS服务器的控制权。通过某些手段修改这些域名的目的解析IP地址。DNS劫持通过篡改DNS服务器上的数据,给用户返回一个错误的查询结果来实现的。 DNS劫持症状:在某些地区的用户在成功连接宽带后,首次打开任何页面都指向ISP提供的“电信

- 阅读全文 -

mac 笔记本下编译安装php 7.3.8

```configure 参数``` 正确的编译参数: ```darrykingerdeMacBook-Pro:php-7.3.8 darry$ sudo ./configure --prefix=/usr/local/Cellar/php7.3.8 --with-iconv=/usr/local/Cellar/libiconv/1.16/ ```输出的结果正常,然后```sudo m

- 阅读全文 -